Salesloft Dialer Disruption
Incident Report for Salesloft
Resolved
This issue can be considered resolved. Thank you for your patience in this matter and apologies for the inconvenience it might have caused.
Posted Dec 07, 2023 - 12:25 EST
Monitoring
Our dialer provider, Twilio, has begun remediating their outstanding issues which blocked a certain subset of Salesloft customers from being able to place calls using the Salesloft dialer. We are seeing the issue slowly recover and teams should be able to start placing calls once again.

We’re monitoring to ensure that their changes have the preferred impact and provide a final update when it has completely recovered. We appreciate your patience in this matter.
Posted Dec 07, 2023 - 08:11 EST
Investigating
We are currently investigating an issue where customers are reporting that the dial pad freezes when clicking the call button on the dialer. This is impacting a certain subset of our customers.

Our dialer provider, Twilio, is currently reporting several issues that may be related but our engineering team is currently investigating. You can monitor status.salesloft.com for further updates.
Posted Dec 07, 2023 - 07:05 EST
This incident affected: 3rd Party Integrations (VoIP Provider).