UI Issue on Salesloft People and Account Pages

Incident Report for Salesloft

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 07:04 EDT

Monitoring

Our engineering team has deployed a fix for the UI issues on People and Account pages. To ensure the changes take effect, please log out and then log back into your Salesloft account.

We will continue to monitor the situation to confirm the fix has had the desired impact. Thank you for your patience and support.
Posted Jul 28, 2025 - 06:05 EDT

Investigating

We're currently investigating an issue affecting the user interface (UI) on People and Account pages. This may cause some unexpected behaviour and/or display problems when viewing these pages. Our engineering team is currently working to identify the cause of this issue.

Please continue to monitor our Status Page for additional updates.
Posted Jul 28, 2025 - 05:05 EDT
This incident affected: Salesloft Web Application.