Google Calendar Integration
Incident Report for Salesloft
Resolved
The updated extension addresses the issues of duplicate calendar invites and meeting titles changing. Users can update to the new version, effectively resolving the issues experienced.

To force an update to the extension you can navigate here in Chrome: chrome://extensions/
Click Developer Mode on the top right
Then click Update on the top left

Thanks for your patience while we worked to release this updated version.
Posted May 31, 2023 - 09:31 EDT
Identified
Our team has identified an issue impacting some GSuite users when creating calendar events. Some customers have reported problems with the title of these events or duplicates when making edits. Once Google has approved our updated extension file that contains the fix for these issues, we will post an update. Thanks for the patience while we work to get this resolved.
Posted May 30, 2023 - 16:42 EDT
This incident affected: 3rd Party Integrations (G-Suite Applications).