Email and Dialer Down

Incident Report for Salesloft

Monitoring

We’ve deployed a fix that should resolve the email and dialer issues. Please refresh your browser to ensure the applied changes take effect. We’re monitoring to ensure the changes have the preferred impact. Continue to monitor the status page for additional updates.
Posted Apr 14, 2026 - 12:09 EDT

Identified

Engineering has identified the root cause and is working on a resolution. Please continue to monitor the status page for additional updates.
Posted Apr 14, 2026 - 10:47 EDT

Investigating

We are currently investigating reports of intermittent issues affecting our dialer and email services. Our team is working to identify the root cause, and we will provide an update as soon as more information is available.
Posted Apr 14, 2026 - 10:41 EDT
This incident affects: Salesloft Web Application.