People Page Unresponsive
Incident Report for Salesloft
Resolved
We can confirm that this incident is now considered resolved. Thanks for your patience.
Posted Mar 29, 2022 - 16:12 EDT
Monitoring
A fix has been implemented and we are confirming that the People page is now accessible again for the subset of customers who experienced the problem. Please refresh your browser and attempt to access the page again. We will continue to monitor the system. Sincere apologies for the trouble.
Posted Mar 29, 2022 - 12:32 EDT
Investigating
We are currently investigating a service disruption for a subset of customers who are having trouble loading the People records page located https://app.salesloft.com/app/v2/people

Our team is working to identify and restore functionality ASAP. Thanks for the patience while we work through it.
Posted Mar 29, 2022 - 12:13 EDT
This incident affected: Salesloft Web Application.