Slower Load Times for Some Customers

Incident Report for Salesloft

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 13:18 EDT

Monitoring

We've implemented a fix, and system performance has returned to normal. Our team will continue to closely monitor the platform to ensure stability.
Posted Jun 04, 2025 - 12:38 EDT

Investigating

We’re currently investigating an issue causing longer-than-expected load times for a subset of customers. Our engineering team is actively working to identify the root cause and restore full performance as quickly as possible.

We’ll share updates here as we learn more.
Posted Jun 04, 2025 - 11:15 EDT
This incident affected: Salesloft Web Application.