Degraded Salesloft Dialer Performance
Incident Report for Salesloft
Resolved
This incident has been resolved.
Posted Dec 10, 2021 - 21:00 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 10, 2021 - 16:45 EST
Monitoring
Our Engineering team has seen significant recovery on the dialer. Most customers should see a return to normal operation. We will continue to monitor this situation for stability. Please continue to monitor our Status Page for additional updates.
Posted Dec 10, 2021 - 16:40 EST
Investigating
Twilio has reported an issue that causes outbound calls to fail or results in a slow connection between Salesloft’s Dialer and the call recipient. This may be experienced in the Salesloft platform or via the Salesloft Connect extension. Our engineering team is quickly working to remediate the issue. Please continue to monitor our Status Page for additional updates.
Posted Dec 10, 2021 - 16:00 EST
This incident affected: 3rd Party Integrations (VoIP Provider).