Degraded Dialer Performance
Incident Report for Salesloft
Resolved
This issue is now considered resolved.
Posted Dec 22, 2021 - 17:00 EST
Monitoring
While Twilio still has some services affected by their outage, the Salesloft Dialer has stabilized. We will continue to monitor this situation to ensure stability. You can stay up to date with this issue at https://status.twilio.com/. You can also continue to monitor status.salesloft.com for additional updates.
Posted Dec 22, 2021 - 16:51 EST
Identified
Twilio has identified the cause of the issue and seeing some recovery. Some users experiencing this issue may now see it subsiding. You can stay up to date with this issue at https://status.twilio.com/. You can also continue to monitor status.salesloft.com for additional updates.
Posted Dec 22, 2021 - 14:04 EST
Investigating
Twilio has reported an issue that is causing call failures and slow connections between Salesloft’s Dialer and the call recipient for some users. This may be experienced in the Salesloft platform or via the Salesloft Connect extension. Additionally, call recordings may be delayed. You can stay up to date with this issue at https://status.twilio.com/. You can also continue to monitor status.salesloft.com for additional updates.
Posted Dec 22, 2021 - 10:35 EST
This incident affected: 3rd Party Integrations (VoIP Provider).