Google Calendar invites not Lofting

Incident Report for Salesloft

Resolved

Our Engineering Team deployed a fix that has resolved the ability to Loft Google Calendar Invites. Please refresh the Salesloft Extension to ensure the applied changes take effect.
Posted Aug 19, 2025 - 14:33 EDT

Identified

We're currently investigating reports of Google Calendar invites not Lofting. Our engineering team is actively working to identify the root cause of this issue. Please continue to monitor our Status Page for additional updates
Posted Aug 19, 2025 - 12:34 EDT
This incident affected: Salesloft Connect (Chrome Extension).