Dialer Performance Degradation
Incident Report for Salesloft
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 16:45 EDT
Update
This incident is now confirmed resolved. Thanks for your patience.
Posted Sep 20, 2021 - 16:42 EDT
Monitoring
As of 2:09 PM EST, the Salesloft Technology team has identified and fixed the underlying issue impacting the dialer extension. This included click to dial functionality and lack of ringing for inbound phone calls.

To ensure your extension applies the fix, disable then re-enable the extension to refresh it. We'll continue to monitor the situation. Thanks for bearing with us while we worked to ensure this was working as expected again.
Posted Sep 20, 2021 - 14:42 EDT
Investigating
We are currently investigating reports from a subset of users that the Dialer is displaying the following error “Phone call could not be made at this time, reload”

Additionally, inbound phone calls will not be ringing the Salesloft App, but still forwarding to voicemail or a forwarding number as expected.

The current workaround for outbound dialing is to use the in-app dialer vs the extension or "click to dial" until we have identified and released a fix for this issue.

Thank you for your patience. We'll get you back to work ASAP.
Posted Sep 20, 2021 - 13:24 EDT
This incident affected: Salesloft Connect (Chrome Extension).