Salesloft Performance Delays
Incident Report for Salesloft
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 09:41 EST
Monitoring
Impacted customers are seeing a return to normal performance as systems are stabilizing. We will continue to monitor this issue to ensure consistent performance. Thank you for your patience while we worked through this.
Posted Nov 09, 2023 - 12:15 EST
Investigating
The Salesloft team is currently investigating an issue for a subset of customers experiencing delays with the loading of the Platform or general unresponsiveness. This is a top priority for our team, and we will update this status page with more details as they are available.
Posted Nov 09, 2023 - 11:42 EST
This incident affected: Salesloft Web Application.