Microsoft Teams Bot
Incident Report for Salesloft
Resolved
We've deployed a fix that has resolved the Microsoft Teams Bot issues. While we recommend using the Teams API as the most secure and efficient method for capturing Teams meetings in Salesloft, the bot is now operational again and includes Active Speaker Detection.

Documentation for the API alternative is below:
Admin Guide: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration-Admin-Guide?language=en_US
User Setup: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration?language=en_US
Posted Nov 13, 2024 - 12:31 EST
Monitoring
As of November 11th, the Microsoft Teams Bot has been updated and can now join and capture recordings from Teams meetings for any user lacking an active API connection to Microsoft Teams.

While we recommend using the Teams API as the most secure and efficient method for capturing Teams meetings in Salesloft, the bot is now operational again. Currently, the bot cannot identify individual speakers, so recordings will not include Active Speaker Detection in the transcript data. This functionality is slated for an upcoming release later this week.

Documentation for the API Solution is below
Admin Guide: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration-Admin-Guide?language=en_US
User Setup: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration?language=en_US

Thank you for your patience and understanding while we work toward a more permanent answer.
Posted Nov 11, 2024 - 17:38 EST
Update
We continue to investigate solutions to resolve this issue.

As of November 6th, to capture recordings, customers must move to our Teams API integration.

If the API Integration is not possible for your organization, we recommend manually recording in Microsoft Teams so that these meetings can retroactively be ingested into Salesloft or uploaded manually after completion until a more permanent solution is reached.

How to manually upload recordings
https://help.salesloft.com/s/article/Upload-a-Recording-in-Conversations?language=en_US

Documentation for the API Solution is below
Admin Guide: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration-Admin-Guide?language=en_US
User Setup: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration?language=en_US

Thank you for your patience and understanding while we work toward a more permanent answer.
Posted Nov 07, 2024 - 09:34 EST
Investigating
The Salesloft team is investigating reports of missing bots from meetings for a subset of customers using Microsoft Teams. Reporting users are not seeing the bot join their meetings and are unable to invite the bot to join manually.

We recommend utilizing the Teams API integrations to ensure your meetings are consistently being captured. Admin and user set up documentation are below.

Admin Guide: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration-Admin-Guide?language=en_US
User Setup: https://help.salesloft.com/s/article/Microsoft-Teams-API-Integration?language=en_US

We will keep this post updated on the status of this issue as we have new information.
Posted Nov 04, 2024 - 18:16 EST
This incident affected: Conversation Intelligence.