Degraded Performance - Dialer
Incident Report for Salesloft
Resolved
We can confirm that the engineering workaround has fixed the issue and that Twilio has now resolved the underlying issue. This incident is now considered resolved. Thanks for your patience.
Posted Mar 28, 2022 - 15:46 EDT
Monitoring
Engineering has made a change to work around a Twilio issue identified as the cause for some users not being able to make outgoing calls. We will be monitoring over the next hour to ensure the stability of this change. Please continue to monitor our Status Page for additional updates.
Posted Mar 28, 2022 - 12:45 EDT
Identified
Engineering has learned that our VoIP provider, Twilio has confirmed an outage for calls being routed through certain regions. While they are working to fix the issue, Salesloft is working on a potential end around to allow affected users to be able to make calls again. Feel free to follow the Twilio incident at status.twilio.com. Please also continue to monitor this Status Page for additional updates.
Posted Mar 28, 2022 - 11:45 EDT
Investigating
We are investigating an issue where some customers are unable to place outbound calls from the Salesloft platform. Our engineering team is quickly working to identify and remediate the issue. Please continue to monitor our Status Page for additional updates
Posted Mar 28, 2022 - 11:16 EDT
This incident affected: Salesloft Web Application.