Issues logging into Drift with the message 'ERROR for site owner: Invalid site key'
Incident Report for Salesloft
Resolved
This incident has been resolved.
Posted Feb 14, 2025 - 09:19 EST
Update
We are still seeing some issues surrounding the login on the mobile app, as well as the reset password flow.
Posted Feb 12, 2025 - 11:03 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 10, 2025 - 12:42 EST
Monitoring
We’ve deployed a fix that has resolved the ability to login to Drift. We’re monitoring to ensure the changes are effective for all users. Continue to monitor the status page for additional updates.
Posted Feb 10, 2025 - 09:51 EST
Identified
Engineering has identified the root cause and is working on a resolution. Please continue to monitor the status page for additional updates.
Posted Feb 10, 2025 - 08:11 EST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2025 - 07:44 EST
Investigating
We are investigating an issue with the Drift login where users are being faced with the error ERROR for site owner: Invalid site key upon login attempt. This seems to be impacting all customers that login using a password (as opposed to SSO). Our engineering team is currently working to identify what is causing this issue. Please continue to monitor our Status Page for additional updates.
Posted Feb 10, 2025 - 06:19 EST
This incident affected: Drift Chat.