Outlook 365 Connection Issues
Incident Report for Salesloft
Resolved
Microsoft is indicating that the Authentication issues have now been completely resolved.
Posted Mar 15, 2021 - 18:30 EDT
Update
Microsoft just posted the following regarding the Authentication outage at https://status.azure.com/en-us/status:

Engineering teams are currently rolling out mitigation worldwide. Customers should begin seeing recovery at this time, with full mitigation expected within 60 minutes.

We will continue to monitor the situation. Please continue to monitor the status page for updates.
Posted Mar 15, 2021 - 17:42 EDT
Identified
Microsoft continues to report authentication errors across it's Cloud platforms: https://status.azure.com/en-us/status. We will continue to monitor the situation. Please continue to monitor the status page for updates.
Posted Mar 15, 2021 - 17:18 EDT
Investigating
We have reports of email disconnections for Outlook 365 users. Microsoft is reporting an outage on their status page related to authentication: https://status.azure.com/en-us/status. Our Engineering team is looking into this as well. Please continue to monitor the status page for updates.
Posted Mar 15, 2021 - 15:56 EDT
This incident affected: 3rd Party Integrations (MS Outlook).