We identified an issue with an internal networking component which caused the slowness. We mitigated the issue by scaling up additional infrastructure. Our metrics show that the latency has returned to normal levels. We continue to the monitor performance and will resolve this incident after 24 hours, once the performance is stable.
Posted Feb 23, 2026 - 16:42 EST
Identified
After initial improvements, we’re now seeing increased latency again in the app. Our team is investigating and implementing additional mitigation. We’ll provide another update within the next 3 hours, or sooner if the issue is resolved.
Posted Feb 23, 2026 - 15:36 EST
Monitoring
Our Engineers have deployed a fix to resolve the overall platform slowness. Please log out and back in to ensure the applied changes take effect. We’re monitoring to ensure the changes have the preferred impact. Continue to monitor the status page for additional updates.
Posted Feb 23, 2026 - 13:02 EST
Identified
Engineering has identified the root cause and is working on a resolution. Please continue to monitor the status page for additional updates.
Posted Feb 23, 2026 - 12:40 EST
Investigating
We are investigating an issue with general slowness within the platform. Our engineering team is currently working to identify what is causing this issue. Please continue to monitor our Status Page for additional updates.