Cellular Carrier Outages
Incident Report for Salesloft
Resolved
Cellular carriers have reported that issues causing call failures are now resolved.
Posted Jun 16, 2020 - 07:28 EDT
Investigating
We have been made aware that some cellular carriers are reporting some call failures on their networks. This can impact SalesLoft users if they are using Passthrough to a cell phone on a network that is experiencing call failure issues. We will continue to monitor the situation and update this page as we learn more.
Posted Jun 15, 2020 - 17:03 EDT
This incident affected: Cellular Carriers.