Drift Service Disruption

Incident Report for Salesloft

Resolved

This incident is now considered resolved. Thank you for your patience and understanding throughout.
Posted Oct 21, 2025 - 08:15 EDT

Monitoring

Earlier this morning, Drift was impacted by the global Amazon Web Services outage. This resulted in the inability to log in and/or navigate the Drift platform, including successfully sending and receiving messages. Systems have since improved, but users may still experience platform performance issues as AWS continues to recover.

We will provide an update once systems have fully recovered.
Posted Oct 20, 2025 - 09:46 EDT
This incident affected: Drift Chat.