Salesforce Extension Buttons Missing

Incident Report for Salesloft

Resolved

This incident is now considered resolved. Thank you for your patience
Posted Jan 28, 2026 - 10:15 EST

Update

This incident is now considered resolved. Thank you for your patience
Posted Jan 28, 2026 - 09:20 EST

Investigating

We are currently investigating reports that Salesforce extension buttons are not appearing as expected within the browser extension. Our engineering team is currently looking into the matter to restore full functionality.
Posted Jan 27, 2026 - 10:00 EST
This incident affected: Salesloft Connect (Chrome Extension).