Platform Performance Issues

Incident Report for Salesloft

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 14:27 EDT

Monitoring

Our engineers have deployed a fix to address the latency and performance issues that were impacting a subset of customers. We are seeing performance return to normal levels and will continue to monitor the system closely to ensure the changes have the intended effect.
Posted Mar 09, 2026 - 10:34 EDT

Investigating

We are investigating reports of increased latency within the platform affecting a subset of customers. Our engineering team is working to identify the root cause. Please continue to monitor this page for further updates.
Posted Mar 09, 2026 - 07:25 EDT
This incident affected: Salesloft Web Application.