British Telecom Outage
Incident Report for Salesloft
Resolved
We've received reports from British Telecom that they have resolved the issue. If you're still experiencing any issues loading the Salesloft application, please check BT's status page by going to the site and placing your information at https://www.bt.com/help/check-service-status
Posted Oct 31, 2022 - 15:59 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 31, 2022 - 10:53 EDT
Monitoring
The ISP, British Telecom is currently reporting outages across the United Kingdom. This will affect all Salesloft functionality. We will continue to monitor the situation and post updates here. You can also view the BT status page by going to the site and placing your information at https://www.bt.com/help/check-service-status.
Posted Oct 31, 2022 - 10:51 EDT
This incident affected: Salesloft Web Application.