Email Delivery Degradation
Incident Report for Salesloft
Resolved
Engineering has identified an issue where customers are seeing a delay in emails being delivered after sending. These delays can last for a few hours. The root cause has been identified and Engineering is working on a fix. Please continue to monitor our Status Page for additional updates.

Update: this is now resolved. Thanks for your patience.
Posted Apr 12, 2022 - 12:00 EDT