Salesloft Service Disruption

Incident Report for Salesloft

Monitoring

Our Engineers have deployed a fix to resolve the platform unresponsiveness. Please log out and back in to ensure the applied changes take effect. We’re monitoring to ensure the changes have the preferred impact. Continue to monitor the status page for additional updates.
Posted May 12, 2026 - 11:18 EDT

Investigating

We are investigating reports of unresponsiveness within the platform affecting a subset of customers. Our engineering team is working to identify the root cause. Please continue to monitor this page for further updates.
Posted May 12, 2026 - 10:02 EDT
This incident affects: Salesloft Web Application.