Salesloft Service Disruption

Incident Report for Salesloft

Resolved

This issue has been resolved. Thank you for your continued patience in this matter.
Posted Jun 10, 2025 - 10:36 EDT

Monitoring

We’ve deployed a fix and are now slowly seeing improvements in platform load times. Please log out and back in to ensure the applied changes take effect.

We’re monitoring to ensure the changes have the preferred impact. Continue to monitor the status page for additional updates.
Posted Jun 10, 2025 - 08:16 EDT

Identified

Engineering has identified the root cause and is working on a resolution. Please continue to monitor the status page for additional updates.
Posted Jun 10, 2025 - 08:01 EDT

Investigating

We're currently investigating reports of Salesloft unresponsiveness across the entire platform. Our engineering team is actively working to identify the root cause of this issue as a top priority. Please continue to monitor our Status Page for additional updates.
Posted Jun 10, 2025 - 03:45 EDT
This incident affected: Salesloft Web Application.