Error Message when Placing Calls from the Salesloft Connect Extension
Incident Report for Salesloft
Resolved
We've deployed a fix that has resolved issues with placing calls from the Salesloft Extension. Please refresh your browser to ensure the applied changes take effect. Thank you for your continued patience in this matter.
Posted Dec 12, 2023 - 12:39 EST
Monitoring
We’ve deployed a fix that has resolved the ability to place outbound calls from your CRM via the Salesloft Connect Chrome extension. Please log out and back in to ensure the applied changes take effect. We’re monitoring to ensure the changes have the preferred impact. Continue to monitor the status page for additional updates.
Posted Dec 12, 2023 - 11:16 EST
Investigating
We are investigating an issue where it has been reported that users are unable to place outbound calls from their CRM via the Salesloft Chrome extension. They receive a banner that mentions the number might be invalid followed closely by an audio message sharing that an error has occurred. This appears to be impacting most customers.

Our engineering team is currently working to identify what is causing this issue. A potential workaround is to place those calls directly from the Salesloft platform. Please continue to monitor our Status Page for additional updates.
Posted Dec 12, 2023 - 06:54 EST
This incident affected: Salesloft Web Application and Salesloft Connect (Chrome Extension).