Salesloft Not Loading
Incident Report for Salesloft
Resolved
We've deployed a fix that has resolved the ability to access Salesloft. Please refresh your browser to ensure the applied changes take effect.
Posted Apr 23, 2024 - 18:33 EDT
Investigating
The Salesloft team is currently investigating an issue for a subset of customers experiencing delays with the loading of the Platform or general unresponsiveness. This is a top priority for our team, and we will update this status page with more details as they are available.
Posted Apr 23, 2024 - 16:32 EDT
This incident affected: Salesloft Web Application.