Dialer Disruption
Incident Report for Salesloft
Resolved
This issue regarding Dialer Disruption should now be resolved. Thank you all for your continued patience in the matter and apologies again for the inconvenience it may have caused.
Posted May 19, 2023 - 08:04 EDT
Monitoring
Twilio has updated their status page stating that they are seeing recovery and are now monitoring to ensure stability (status.twilio.com)

We will be monitoring from here as well. Also, upon further review, the impact of the Twilo outage has been affecting all customers, not just customers with Live Call Studio.

You can continue to monitor status.salesloft.com for further updates
Posted May 18, 2023 - 21:11 EDT
Identified
Engineering has confirmed that the Twilio outages are causing the dialer issues in Salesloft. They have also confirmed that this issue is only affecting customers with the Live Call Studio feature turned on. Engineering investigating if they can work around this issue. You can continue to monitor status.salesloft.com for further updates.
Posted May 18, 2023 - 21:00 EDT
Investigating
We are currently investigating an issue where customers are reporting that their page freezes when clicking the call button on the dialer.

Our dialer provider Twilio is reporting 2 issues that may be related but our engineering team is currently investigating. You can monitor updates for Twilio at status.twilio.com. You can also monitor status.salesloft.com for further updates.
Posted May 18, 2023 - 20:07 EDT
This incident affected: 3rd Party Integrations (VoIP Provider).