Costello Incident
Incident Report for SalesLoft
Resolved
We've deployed a fix that has resolved the ability access Costello. Please refresh your browser to ensure the applied changes take effect.
Posted Feb 07, 2020 - 08:30 EST
Identified
We are currently experiencing issues with the Deals (formerly Costello) integration which is impacting access to that portion of the SalesLoft application. Our engineering team has identified the issue and is working on a solution. Please continue to monitor this page for additional updates.
Posted Feb 07, 2020 - 07:59 EST
This incident affected: SalesLoft Web Application.