Microsoft Email and Calendar connectivity
Incident Report for Salesloft
Resolved
We've continued to monitor the Microsoft 365 service issue and we are seeing significant improvements with Office 365 connected email users. If an email failed during this time you can retry it from the email page or re-run the cadence email step when the email failed. If you have any questions or issues you can contact our Support at https://support.salesloft.com/hc/en-us/requests/new
Posted Sep 29, 2020 - 11:03 EDT
Monitoring
Microsoft has shared via its status.office.com that the majority of services have recovered. However they report a small number of tenants in the North America region that are still impacted. We will continue to monitor the status.office.com page and provide updates as they are shared but we also encourage monitoring the status.office.com directly for real-time updates
Posted Sep 28, 2020 - 23:11 EDT
Identified
Microsoft is investigating an issue affecting access to multiple Microsoft 365 services, for Salesloft this will disrupt your email and calendar connection. You can keep track of this issue at their status page, status.office.com.
Posted Sep 28, 2020 - 18:40 EDT
This incident affected: 3rd Party Integrations (MS Outlook).