On-Premise Exchange Customers - Email and Notification Delays
Incident Report for SalesLoft
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 14, 2019 - 17:02 EST
Investigating
Customers with on premise Exchange email may see delays with email and notifications due to an outage with our 3rd party processing vendor, Nylas. The Operations team is currently monitoring the process.
Posted 4 months ago. Feb 14, 2019 - 10:49 EST
This incident affected: 3rd Party Integrations (Nylas).