SalesLoft.com Website Under Maintenance
Incident Report for Salesloft
Resolved
The Salesloft.com website maintenance is now complete and is back online.
Posted Mar 29, 2019 - 13:00 EDT
Update
The SalesLoft website (SalesLoft.com) is undergoing maintenance. The SalesLoft Platform is not impacted and still accessible at accounts.SalesLoft.com.
Posted Mar 29, 2019 - 13:00 EDT
Update
The SalesLoft.com website is operational again. If you are still having trouble accessing SalesLoft.com please connect with support@SalesLoft.com so we can help get everything back up and running.
Posted Mar 29, 2019 - 12:54 EDT
Investigating
The SalesLoft website (SalesLoft.com) is undergoing maintenance. The SalesLoft Platform is not impacted and still accessible at accounts.SalesLoft.com.
Posted Mar 29, 2019 - 10:20 EDT
This incident affected: Salesloft.com Website.