Degraded Salesloft Dialer Performance
Incident Report for Salesloft
Resolved
Twilio has officially marked this incident as resolved. https://status.twilio.com/incidents/tmxh0lcbqg3w

Thanks for your patience as this was being worked on.
Posted Dec 14, 2022 - 13:30 EST
Monitoring
Our VoIP Provider, Twilio, has confirmed that dialing is back to normal operations. We will continue to monitor this issue and provide updates as they become available.
Posted Dec 14, 2022 - 13:09 EST
Identified
We are investigating an issue where some customers are unable to place outbound calls from the Salesloft platform.

Twilio (our VoIP provider) has reported an issue that causes outbound calls to fail or results in a slow connection between Salesloft’s Dialer and the call recipient. https://status.twilio.com/incidents/tmxh0lcbqg3w

This may be experienced in the Salesloft platform or via the Salesloft Connect extension. Twilio's engineering team is working to correct this issue. Please continue to monitor our Status Page for additional updates.
Posted Dec 14, 2022 - 12:49 EST
This incident affected: 3rd Party Integrations (VoIP Provider).